Jump to content
Sign in to follow this  
nerone

Sh3 E Windows 7: Non Va

Recommended Posts

Avevo il tuo stesso problema, con Windows 7.

Ho installato il gioco da DVD originale e c'ho messo la PatchNoDVD

 

Tutti i rimedi relativi ai driver Starforce sono stati inutili.

 

Saluti

 

 

Ciao Nihira, ora anche io ho questo problema avendo rinnovato il mio pc ( ora anche con window 7 ) . Puoi suggerirmi dove trovare la Patch noDVD ?

Grazie comunque.

Share this post


Link to post
Share on other sites

Ciao ragazzi! Prima di tutto vi faccio gli auguri di buon Natale! Vi scrivo perché è da un po' che non gioco e vorrei reinstallare sh3. Ho anche il 5 ma non credo che abbia avuto quel successo del 3. E mi è tornata la voglia di reinstallare sh3 Ebbene ho avuto una spiacevole sorpresa. Io ho come sistema operativo il win 7 64 bit e quando vado per lanciare il gioco mi da l'errore che ha dato ad alcuni di voi. Che il sistema funziona solo per win xp/ 95 ecc.ecc. Ora ho provato a fare di tutto, ho scaricato il tool per togliere la starforce ma invano. Ho cercato qualche sito per scaricare la patch no dvd ma non c'è un sito affidabile. Mi potete dare qualche dritta? Se sapete dove poterla scaricare mi potete mandare il link con un mp? Grazie mille

Share this post


Link to post
Share on other sites

Ciao ragazzi! Prima di tutto vi faccio gli auguri di buon Natale! Vi scrivo perché è da un po' che non gioco e vorrei reinstallare sh3. Ho anche il 5 ma non credo che abbia avuto quel successo del 3. E mi è tornata la voglia di reinstallare sh3 Ebbene ho avuto una spiacevole sorpresa. Io ho come sistema operativo il win 7 64 bit e quando vado per lanciare il gioco mi da l'errore che ha dato ad alcuni di voi. Che il sistema funziona solo per win xp/ 95 ecc.ecc. Ora ho provato a fare di tutto, ho scaricato il tool per togliere la starforce ma invano. Ho cercato qualche sito per scaricare la patch no dvd ma non c'è un sito affidabile. Mi potete dare qualche dritta? Se sapete dove poterla scaricare mi potete mandare il link con un mp? Grazie mille

 

Prima cosa......hai provato ad abbassare la risoluzione a 1024x768 ?

Altro tentativo, metti l'eseguibile di SH in modalità compatibilità. Facci sapere !!!

Share this post


Link to post
Share on other sites

Buongiorno C.te Von Faust! E' un piacere risentirti! Si ho sistemato! Purtroppo la mia versione di Sh3 ha la Starforce e quindi ho dovuto scaricarmi la patch NoCd altrimenti non c'èra nulla da fare. Ho provato ad avviarlo come amministratore, come SP 2, come XP ma niente da fare, sempre il solito messaggio che il programma è stato fatto per sistemi operativi win 95/Xp ecc.ecc. E questo dipende solo da quella c.....ta di Starforce. Poi ho scoperto appunto che devo cambiare risoluzione dello schermo a 1024X768, inoltre avendo un Widescreen vedo l'obbiettivo del peri leggermente schiacciato.

Anzi sarei quasi propenso ad acquistare un nuovo Sh III senza la Star force. Su ebay e Amazon qualcosa forse si trova, ma come si fa a sapere se hanno Starforce o no?

Share this post


Link to post
Share on other sites

con w 7 neanche a me va.

le sto provando di tutte.lo installo e mi da un errore (can't create an object).

liscio va anche.ma se lo aggiorno alla 1.4 non parte piu'.

sapete aiutarmi.?

su i bay ne ho trovati di nuovi ancora impachettati a 10 euro sia sh3 che sh5.........li vorrei prendere ma se poi non vanno...........

Share this post


Link to post
Share on other sites

Io gioco regolarmente a SH3 moddato con GWX-3.0 e Windows 7 64bit.

 

Io ho fatto questi passaggi.

 

- Installazione di SH3 base (il mio non è la versione Steam ma una vecchissima versione su DVD acquistata anni fà. Io ho installato SH3 non nella solita cartella Programmi ecc.. ma sotto Users/mioutente/AppData/Silent Hunter III (il nome della cartella di SH3 ho lasciato quella suggerita da lui ho solo cambiato il path)

- Riavvio

- Installazione Patch 1.4 eseguendola come Admin

- Riavvio

- Test di gioco

Se tutto OK proseguo con i mod

 

A me questa procedura è sempre andata, l'ho reinstallato almeno 2 volte così in due pc diversi con lo stesso Sistema operativo e anche con Vista stesse modalità.

Ultimamente devo proprio reinstallare in questi giorni perchè ho formattato, in caso farò avere una lista degli step più precisa compresi i mod

Share this post


Link to post
Share on other sites

non so che dire...io installo il gioco - mi dice che c'e' un errore - 429 - can't create an object - ma va lo stesso ho provato a giocare.

quindi vado con la patch 1.4 b e poi non parte piu.!carica la famosa barra rossa e poi esce fuori il messaggio che ha smesso di funzionare.

sono quasi deciso a passare al 5.comprandolo e installando la mega mod.

pero' il 3 e' il 3..per me il migliore...senza sara' dura

Share this post


Link to post
Share on other sites

non so che dire...io installo il gioco - mi dice che c'e' un errore - 429 - can't create an object - ma va lo stesso ho provato a giocare.

quindi vado con la patch 1.4 b e poi non parte piu.!carica la famosa barra rossa e poi esce fuori il messaggio che ha smesso di funzionare.

sono quasi deciso a passare al 5.comprandolo e installando la mega mod.

pero' il 3 e' il 3..per me il migliore...senza sara' dura

 

Hai provato ad abbassare la risoluzione a 1024x768 o ad impostare l'eseguibile di SH in modalità compatibilità ?

Share this post


Link to post
Share on other sites

si, le ho provate tutte.

la macchina e' stata formattata 5 giorni fa,quindi e' a posto.

mi si e' bruciato l'hd dopo 9 anni di servizio...............

adesso riprovo ancora seguendo tutti gli step di regia marina e dell'altro user.

faro' cosi.vedete se sbaglio anche voi

1 faccio partire lo star force remove.

2 controllo bene che non ci siano cartelle di sh3 di una precedente installazione

3 installo il gioco,mi da a fine installazione l'errore can't create an object - 429 -non installo game shadow non riavvio quando lo chiede.

4 insallo la patch emea i.4 b.il gioco non parte piu'.al momento di arrivare alla pagina del menu' appare l'errore di windows che ha smesso di funzionare.

6 provo a cambire la risoluzione

7 provo a farlo partire come amministratore

8 provo a eseguirlo in xp sp2 xp sp3.

ma niente,non va.

per esperienza sara' una cavolata.son sempre riuscito a far partire tutti i giochi.

o sbaglio qualcosa.o c'e' qualcosa che non va nel mio pc.ma mi sembra strano visto che e' appena uscito dal negozio.

l'errore can't create an object - 429 lo da ad altri o solo a me?avrei trovato una guida x risolverlo ma e' un po' complicata e c'e' da paciugare un po' e vorrei evitarlo.

Edited by Von Faust

Share this post


Link to post
Share on other sites

ce l'ho fatta!!!!!!

non ho capito come,dato che ho fatto come le 8 volte precedenti.............

ma l'importante e' che posso tornare in mare........a quel paese sh5..........e giu' di gw 3.

una cosa vi chiedo.ogni volta che gioco dovro' cambiare la risoluzione dello schermo?o devo solo cambiare quella del gioco.se cosi' da dove?

Share this post


Link to post
Share on other sites

ce l'ho fatta!!!!!!

non ho capito come,dato che ho fatto come le 8 volte precedenti.............

ma l'importante e' che posso tornare in mare........a quel paese sh5..........e giu' di gw 3.

una cosa vi chiedo.ogni volta che gioco dovro' cambiare la risoluzione dello schermo?o devo solo cambiare quella del gioco.se cosi' da dove?

Io la risoluzione di Windows non la modifico mai. Ma ti va di nuovo in errore se non la modifichi ?

 

EDIT: ora che mi viene in mente ho installato una mod che consente risoluzioni superiori alla 1024, ti saprò dire quale.

Edited by Von Faust

Share this post


Link to post
Share on other sites

si se la metto al massimo 1920 1080 mi dice connot initializate 3d engine

per il resto tutto bene.

solo sh3 commander mi da probblemi....come l'ho installato andava,poi ho messo dentro 2 3 mod e ora non mi da piu il menu option.

ma e' la meno.l'importante e' che ora posso giocarci.

Share this post


Link to post
Share on other sites

Ho risolto anche s H 3 commander

Si impallava con il cambio di risoluzione.

Ieri ho testato tutte le mod che avevo prima su xp.

Tutto ok

Mi mancano solo 2 cose.

Se mi potete aiutare la mod del vento sul ponte come si chiama?

E quella che mette le faccine dei personaggi del film das boat...ho quella x gli abiti

Grazie

Share this post


Link to post
Share on other sites

saluti a tutti, come da post letti ho installato SH3 in Win7 64 e dopo averlo aggiornato alla 1.4 il software non partiva. Solito messaggio " compatibile con..." le ho provate tutte con le indicazioni trovate in rete. Alla fine ho copiato nelle cartella i 5 file per farlo partire senza dvd, adesso parte. Ho scaricato Lili Marlene 1.4 e installata, fin quì tutto bene. Lancio SH3 e vedo che non sono cambiati i testi, sono sempre in inglese o tedesco. Come posso fare?

 

Grazie per le risposte

Share this post


Link to post
Share on other sites

Scusate, problema risolto. Quando installavo Lilly Marlene l'auto installante me lo metteva in C/Programmi/Ubisoft e non in C/Programmi (x86)/Ubisoft resta il dubbio che non vada senza cambiare l'eseguibile e gli altri file.... misteri.

Share this post


Link to post
Share on other sites

Il mio no

Mi rassegno, cambierò risoluzione ogni volta......

 

Ronde77 io riesco ad utilizzare risoluzioni maggiori dopo aver messo all'interno della cartella principale di SH3 i file "d3d9.cfg" e "d3d9.dll" se fai qualche ricerca in rete aggiungendo la chiave silent hunter 3 dovresti trovare qualche cosa.

Dopo aversi scaricati editi il file d3d9.cfg ed imposti la risoluzione del tuo desktop (nel mio caso 1920x1080). Ti copio/incollo il contenuto del mio:

 

;

; DX9res Settings

; by Kegetys kegetys@dnainternet.net>

;

; Note that this config is reloaded on device reset, so you can task switch out

; of the game, change settings from this file and then return

;

[config]

; ResX: Horizontal resolution setting

; ResY: Vertical resolution setting

; useFiltering: Use linear filtering for UI elements

; enableScreenshots: Hook printscreen keypress to save TGA screenshot

resX=1920

resY=1080

useFiltering=1

enableScreenshots=1

screenshotPath=.

[gamma]

; setGamma: Override gamma ramp

; gammaRed: Red channel gamma (1.0 = normal, decrease to add brightess, increase to darken)

; gammaGreen: Green channel gamma (1.0 = normal, decrease to add brightess, increase to darken)

; gammaBlue: Blue channel gamma (1.0 = normal, decrease to add brightess, increase to darken)

setGamma=0

gammaRed=1.0

gammaGreen=1.0

gammaBlue=1.0

Share this post


Link to post
Share on other sites

Un saluto a tutti, sopo essere stato in esilio per molti anni ora che ho deciso di reinstallare SH3 purtroppo vedo che non va nulla.. per quello ritiro su questa discussione nel caso qualcuno avesse una soluzione efficace

Premetto che ho letto e seguito quello che ho trovato qui e altrove ma sembra che tutti riescano in qualche modo ma io no

 

WIn 7 64bit, installazione finita lancio il gioco ma esce la finestrella che dice il gioco non può essere avviato se non con xp,vista etc..

non so se sia la starforce o meno dato che non la leggo da nessuna parte ma la la finestrella di errore sembra quella, il gioco lo ho acquistato molti anni fa e ci avevo giocato su XP e anche li ricordo qualche volta non partiva e dovevo insistere

comunque..

Provato la no cd patch ma nulla, provato la patch 1.4 che avevo salvato da tempo nell'hard disk ma nulla, provato a fare compatibilità con XP, vista etc. ma niente

 

Disinstallato :sleep:

 

Che faccio? mi metto l'anima in pace e non ci gioco più?

nessuno di voi ha lo stesso sistema operativo?

Share this post


Link to post
Share on other sites

First of all grazie del link, nel mio girovagare non l'avevo trovato

ma.. sembrava tutto troppo bello per essere vero ed infatti ho combinato poco

 

Fatto tutto seguendo alla lettera ma l'unica cosa che è cambiata è che quando vado a lanciare il gioco non esce più nessuno errore ma semplicemente non succede nulla :biggrin:

rifatto tutto un altra volta, si sa mai che abbia dimenticato qualcosa, ma stessa cosa

 

Ho provato a collegarlo all'account steam credendo che mi chiedesse il numero seriale per scaricarlo senza comprarlo di nuovo ma se ne frega quindi l'ho riacquistato (e sta cosa mi scoccia assai..) e lo sto scaricando ora

Vediamo se risolvo

Grazie

Edited by The Steel Coffin

Share this post


Link to post
Share on other sites

Niente da fare

Nemmeno da steam funziona e a sto punto allora la starforce non c'entra nulla, già chiesto il rimborso

 

l'unica cosa sarebbe provare a mettere un exe funzionante dentro la mia cartella ma non so dove reperirlo e nei siti pirati e sharing di tutto mica ci vado, sto tirando giù il rosario completo..

Share this post


Link to post
Share on other sites

Niente da fare

Nemmeno da steam funziona e a sto punto allora la starforce non c'entra nulla, già chiesto il rimborso

 

l'unica cosa sarebbe provare a mettere un exe funzionante dentro la mia cartella ma non so dove reperirlo e nei siti pirati e sharing di tutto mica ci vado, sto tirando giù il rosario completo..

È molto strano non funzioni nemmeno con Steam, l'exe non c'entra.quello di Steam è perfetto,e secondo me hai sbagliato a chiedere subito il rimborso avevi una installazione che sicuramente avrebbe funzionato, vedrò se in giro trovo qualcosa... Ma con Steam quando lo lanciavi che errore ti dava?

E quali sono le specifiche del tuo PC?

Il gioco ce l'hai in DVD ora?

Originale?

Ed un'ultima cosa a quale risoluzione lo stavi provando con Steam?

Con più informazioni magari qualcosa possiamo fare

Edited by prima_legio

Share this post


Link to post
Share on other sites

Grazie per l'interessamento

Con steam non partiva e mi dava un errore non ricordo quale ma semplicemente che non poteva avviarlo

Come risoluzione intendi quella che ho io di default del video dici? sto a 1920x1200 ma avevo provato a modificare il file come diceva nella guida del tuo link per metterla come diceva il tizio ma non cambiava nulla, di certo non cambio la risoluzione totale del mio sistema per un gioco altrimenti mi troverei sballato con tutto il resto

 

Si certo il DVD è originale quello che all'interno ha anche la mappa di carta, credo lo acquistai nel 2005/2006

Riguardo a steam, gli ho anche fatto fare la verifica dei file e mi ha detto tutto a posto, di più non saprei sembra strano anche a me che ad altri va e a me no, meraviglie dell'informatica

Lo posso sempre ricomprare se serve ma a sto punto il problema sta altrove, forse forse le direct x? ma le schede recenti han tutte le 11 non le vecchie 9..

 

Mio sistema è un core duo 8400, schermo wide 24 a 16:10 (1920x1200), scheda video gtx 1050 ti e ram 8 giga

A breve lo upgraderò con nuova CPU,motherboard e ram ma prima devo fare un po di musina :laugh:

Edited by The Steel Coffin

Share this post


Link to post
Share on other sites

edit ho corretto il rapporto dello schermo che ovviamente è di 16:10 non come la cacchiata che avevo scritto per sbaglio :laugh:

Mi ripeto dicendoti che per me hai sbagliato a restituire la versione Steam.. è perfettamente funzionante.

Il tuo DVD sicuramente ha la starforce ed il tuo problema "funziona solo con XP, Vista ecc"

è dovuto a questo.

Però credo hai anche un problema di risoluzione schermo e credo sia per questo che avevi problemi con Steam a meno che tu non abbia impedito l'installazione delle directX da Steam, che non ti avrebbero creato nessun problema, ma non sapendo di preciso quale errore ti dava non posso proprio aiutarti, mi spiace

 

PS di dove sei? Musina..veneto o trentino? :)

Edited by prima_legio

Share this post


Link to post
Share on other sites

ovviamente in veneto! ma se proseguo qualche km ancora sconfino :biggrin:

 

Steam nei requisiti riporta quest: OS: Windows 2000 / XP(only)

io ho provato lo stesso ma senza troppe pretese, non gli ho impedito nulla ho lasciato finire l'installazione ma andando a lanciarlo usciva un messaggio in cui diceva che non era possibile, ma mica ha specificato cosa

Non capisco che problema possa essere la risoluzione francamente, o meglio, sarà forse quello il problema ma mi è impossibile risolverlo a meno che non cambio monitor e faccia girare tutto il mio sistema alla risoluzione a lui congeniale, mi aspetto semmai che il gioco parta almeno fino alle opzioni e che da dentro di esso mi faccia settare la risoluzione che lui vuole in modo da usarla solo per lui

 

Così tanto per fare una contro-contro prova ho cercato e trovato il gioco da scaricare dalla rete, mica per tener quello ovvio ma solo per vedere se quella installazione fosse a posto, nulla nemmeno li..

per questo credo proprio il problema non stia ne da steam ne dalla starforce, il problema come al solito è tra la sedia e la tastiera ( :laugh: ) ma io più in la non so andare e tocca che mi metto l'anima in pace

Share this post


Link to post
Share on other sites

vr città? e alora w lesso e pearà! (questa ovviamente la capiscono in pochi sorry per l' ot :tongue:)

 

Allora ricapitoliamo, ora non ho nulla sul pc dato che ho disinstallato e cancellato tutto

Dal DVD originale dava errore "funziona solo con XP, vista etc.."

sempre da DVD ma con la guida seguita dal tuo link non esce nessun errore riconducibile a starforce ma non succede proprio nulla

Da steam dava errore generico, solo un "impossibile far partire il gioco" o qualcosa del genere

la piratata scaricata per controprova, semplicemente non partiva nulla e

 

ora un dubbio che è l'unica cosa che mi è venuta in mente, è possibile che il lancio del gioco sia estremamente lungo per qualche astruso motivo?

perchè io aspettavo uno/due minuti e basta poi basta ma ho visto in una prova (forse quella fatta da steam) che da gestione applicazioni avevo un processo SH.exe avviato, solo che in quel caso erano passati sicuri più di cinque minuti

 

Quindi qualcosa stava macinando nel mio pc ma chissa cosa

 

Aggiungo questo non so se può aiutare, avviando l'exe dell'editor missioni non partiva e dava lo stesso errore starforce anche lui ma questo solo nel primo caso dal mio dvd perchè in tutti gli altri casi l'editor partiva e sembrava funzionante (non lo ho mai usato quindi nemmeno so come si faccia) dico "sembrava" perchè dall'installazione del link postato sopra si apriva ma rimaneva una mappa non centrata nella finestra e con scritte/simboli che andavano fuori da essa quindi un po tutta sfalsata, da steam invece sembrava tutto a posto e funzionante coi menù etc..

Share this post


Link to post
Share on other sites

Le finestre sfalsate son dovute ad una non corretta installazione,mancanza anzi, di DirectX corrette ( quelle che invece Steam ti aveva autoinstallato )

Poi SH è una simulazione, non è un arcade o uno sparatutto, ci vuole un po' di pazienza nel caricarlo, e non ne hai vedo...e ce ne vuole molta di più nel giocarci,far pattuglie vedendo 0 navi o solo qualche nave nostra alleata e quindi non affondabile, credo sia capitato a tutti. Insomma senza pazienza non parti col piede giusto!

Qui credo che ti possiamo aiutare, ma non devi fare e disfare le installazioni. Porta pasiensa Steel!!!

:)

Edited by prima_legio

Share this post


Link to post
Share on other sites

Capisco perfettamente quello che vuoi dire, peccato solo lo stai dicendo alla persona sbagliata credimi :wink:

spiace essere etichettato e liquidato così ma tant'è

 

Lo vedi l'avatar mio? immagino proprio tu non sappia cosa sia

è lo stemma del Power & Glory ovvero la mod più grandiosa che ci sia per GTR2, con fisica rifatta in maniera certosina per gomme dell'epoca etc.., a cui io ho avuto la fortuna di dare una mano col betatestaggio, un amante degli arcade secondo te potrebbe dedicare tanto tempo e passione a ciò?

Da sempre AMO le simulazioni sopratutto quelle automobilistiche e senza nessun aiuto alla guida ma solo bestemmie e sudore quindi non son certo il tipo da meritarsi una ramanzina del genere dato che ho ben presente credimi la pazienza che bisogna avere nell'apprendimento dei simulatori, con Grand Prix legends neanche immagini quanto tempo speso in ricerche e per settarlo con tutte le cose/patch per permettergli di girare oggi come vent'anni fa

 

Sulla difficoltà di SH3 ti svelo che se è qualche anno che non ci gioco non vuol dire che non sappia cosa sia, è più di un decennio che lo posseggo ed è stato molto tempo installato passandoci molte molte ore/giorni a smadonnare per uno (molti) bersagli mancati/siluri difettosi/Destroyer che mi mandano in fondo all'oceano, ma con questo non sono qui a dire che in mare me la so cavare anzi son totalmente ignorante di navigazione e ci sta che a livello 100% nemmeno riesca ad uscire dal porto altro che calcolare la rotta etc.. ma un passo alla volta ci volevo arrivare e ora volevo appunto riprendere in mano il gioco per continuare l'apprendimento

 

Se steam mi ha installato qualcosa che ci vuole per farlo funzionare ma il gioco non funziona lo stesso non è che posso mettermi li a setacciare tutti i bit del pc sperando di trovare una soluzione, mi aspetto che il gioco funzioni, punto, specialmente dopo averci perso mezza giornata piena con prove e varie installazioni

Ti ringrazio lo stesso e buona navigazione (almeno a te che puoi)

Share this post


Link to post
Share on other sites

Se ho dato l'idea di " liquidarti" o farti la ramanzina ti chiedo scusa perché non intendevo assolutamente questo.

Anzi ci ho messo pure uno smile alla fine proprio per far capire il tono alla buona..

L'unica cosa che conta è che se vuoi ti possiamo aiutare ad installare... Però resta con una installazione prova chiedi e riprova in base ai consigli, magari se puoi fare uno screenshot dell'errore può essere ancora più utile.

Con più gente gioca a SH3 meglio è.

Quindi ripeto le mie scuse.

Ciao :)

Share this post


Link to post
Share on other sites

Da sempre AMO le simulazioni sopratutto quelle automobilistiche e senza nessun aiuto alla guida ma solo bestemmie e sudore quindi non son certo il tipo da meritarsi una ramanzina del genere dato che ho ben presente credimi la pazienza che bisogna avere nell'apprendimento dei simulatori, con Grand Prix legends neanche immagini quanto tempo speso in ricerche e per settarlo con tutte le cose/patch per permettergli di girare oggi come vent'anni fa

 

Ah GP Legend, gran titolo. Attualmente corro su GT Sport (con volante e tutto il resto). Ok, passo al nostro SH :wink:

 

Sulla difficoltà di SH3 ti svelo che se è qualche anno che non ci gioco non vuol dire che non sappia cosa sia, è più di un decennio che lo posseggo ed è stato molto tempo installato passandoci molte molte ore/giorni a smadonnare per uno (molti) bersagli mancati/siluri difettosi/Destroyer che mi mandano in fondo all'oceano, ma con questo non sono qui a dire che in mare me la so cavare anzi son totalmente ignorante di navigazione e ci sta che a livello 100% nemmeno riesca ad uscire dal porto altro che calcolare la rotta etc.. ma un passo alla volta ci volevo arrivare e ora volevo appunto riprendere in mano il gioco per continuare l'apprendimentospecialmente dopo averci perso mezza giornata piena con prove e varie installazioni

Ti ringrazio lo stesso e buona navigazione (almeno a te che puoi)

 

Come detto da prima_legio (che ringrazio per i suoi utilissimi post) sarebbe utile vedere gli errori che ti da.

Io a breve lo reinstallo, con non pochi brividi perché sarà come darmi una mazza sul piede visto che anch'io per riuscire a farlo funzionare (Ho win10 64 bit) ho passato un bel po' di tempo a tirare testate sulla scrivania :wink:

Share this post


Link to post
Share on other sites

Dato che ho trovato una buona offerta ho preso CPU/motherboard nuovi così non ho più reinstallato perchè lo farò dopo aver montato e configurato il "nuovo" pc

sicuro ci metterò ancora il Win7 ma non escludo di provare/passare al 10 sempre a 64 bit

 

Comunque dato che sò de coccio (tipica espressione dell'alto veronese :laugh::laugh: ) ho acquistato dalla Germany un altro DVD del gioco il quale è più recente in quanto seconda o terza edizione quindi al 90% privo della signora starforce

Se mi arriva a casa prima questo dei pezzi PC facile che farò una prova di installazione ugualmente

Vi dirò :smile:

Share this post


Link to post
Share on other sites

Dato che ho trovato una buona offerta ho preso CPU/motherboard nuovi così non ho più reinstallato perchè lo farò dopo aver montato e configurato il "nuovo" pc

sicuro ci metterò ancora il Win7 ma non escludo di provare/passare al 10 sempre a 64 bit

 

Con Win 7 vai su un prodotto sicuro, comunque Win 10 non è da meno

 

Comunque dato che sò de coccio (tipica espressione dell'alto veronese :laugh::laugh: ) ho acquistato dalla Germany un altro DVD del gioco il quale è più recente in quanto seconda o terza edizione quindi al 90% privo della signora starforce

Se mi arriva a casa prima questo dei pezzi PC facile che farò una prova di installazione ugualmente

Vi dirò :smile:

 

Se poi devi rasare tutto ti conviene. Fai tutti esperimenti che vuoi senza troppi scrupoli

Share this post


Link to post
Share on other sites

Dato che ho trovato una buona offerta ho preso CPU/motherboard nuovi così non ho più reinstallato perchè lo farò dopo aver montato e configurato il "nuovo" pc

sicuro ci metterò ancora il Win7 ma non escludo di provare/passare al 10 sempre a 64 bit

Ciao Steel Coffin

Ricorda una cosa qualunque sistema utilizzi crea una cartella "Giochi"

E fai in modo che il tuo DVD installi il gioco lì, non lasciare che lo installi nella cartella "programmi (x86) che è la cartella predefinita, perché questa qua è una cartella protetta e ti potrebbe dare noie con le mod.

Ciao :smile:

Edited by prima_legio

Share this post


Link to post
Share on other sites

Solitamente non lascio installare nulla nella x86 ma semplicemente creo una cartella in C: con il nome del gioco/software direttamente senza passare da una altra cartella nominata ad esempio Giochi, credo sia la stessa cosa

Grazie per la dritta neanche sapevo che era una cartella protetta

Share this post


Link to post
Share on other sites

Solitamente non lascio installare nulla nella x86 ma semplicemente creo una cartella in C: con il nome del gioco/software direttamente senza passare da una altra cartella nominata ad esempio Giochi, credo sia la stessa cosa

Grazie per la dritta neanche sapevo che era una cartella protetta

Si si è la stessa cosa

La cartella (x86) ti può creare problemi anche se deciderai di installare patch tipo "Hsie" "Stiebler" e altre che modificano direttamente sh3.exe

Quindi è meglio tenere il gioco da qualunque altra parte

Ciao.. Adesso vado al Vinitaly..ma no in fiera che vogliono 85 euri!!!!

Stasera meglio che lasci il mio u-boat in garage eheheheh

Ciao :smile:

Edited by prima_legio

Share this post


Link to post
Share on other sites

Dopo anni sto reinstallando SHIII sul PC con Windows 10 (precedentemente lo usavo con XP).
Avendo un CD del 2005 che nel Readme dice essere versione 1.4, devo ugualmente istallare la Patch per poter poi istallare GWX?

Share this post


Link to post
Share on other sites

Dopo anni sto reinstallando SHIII sul PC con Windows 10 (precedentemente lo usavo con XP).

Avendo un CD del 2005 che nel Readme dice essere versione 1.4, devo ugualmente istallare la Patch per poter poi istallare GWX?

 

Direi di no se è già patchato di suo con la 1.4b. Nel dubbio potresti comunque provare ad installarla, non credo succeda nulla.

Share this post


Link to post
Share on other sites

Torno qui per aggiornare la situazione just for curiosity mica perchè importante

Avevo messo in stallo il tutto e ho upgradato il pc e ora ho Windows 10 64bit, riprovato la versione di steam e stavolta va che è un piacere, l'unica accortezza è che ho dovuto settare la compatibilità con XP ma va bene così

Riprovato ad installare anche dal DVD ma nulla addirittura da errore e non trascrive nulla, poco male mi terrò la versione steam anche se non amo molto quel sistema

 

E da qui appunto la prima domanda, quando ci giocavo ero solito tenere una versione "liscia" o con mod di comprovata affidabilità e un'altra installazione con mod e prove varie, ora vedo che la versione steam però non è sdoppiabile nel senso che anche se ne faccio una copia quest'ultima da errore e non fa partire quindi il gioco

Come si potrebbe risolvere?

 

Edited by The Steel Coffin

Share this post


Link to post
Share on other sites
34 minutes ago, The Steel Coffin said:

 

E da qui appunto la prima domanda, quando ci giocavo ero solito tenere una versione "liscia" o con mod di comprovata affidabilità e un'altra installazione con mod e prove varie, ora vedo che la versione steam però non è sdoppiabile nel senso che anche se ne faccio una copia quest'ultima da errore e non fa partire quindi il gioco

Come si potrebbe risolvere?

 

Non ho steam e non conosco bene come "funziona" ma...

Quando fai la copia lanci SH direttamente dalla nuova cartella o la rinomini come quella originale ?

So che in giro ci sono applicazioni che gestiscono installazioni multiple di SH ma non so se son valide per steam.

Nel fare ricerche ho trovato questo, non c'entra nulla con l'argomento ma può essere utile:

 

Prerequisites

Clean Install

First make sure you have a clean and fresh install of Silent Hunter III. If you are doing a clean installation of the game after reading this guide make sure after uninstalling from your Steam library to remove the old folders:
 
  1. C:\Program Files (x86)\Steam\steamapps\common\Silent Hunter 3
  2. C:\Users\Username\Documents\SH3
 
Compatibility Mode

Unfortunately Silent Hunter III is that old and requires to be run as administrator and in compatibility mode. What worked for me is Windows XP Service Pack 3.
 
  1. Navigate to C:\Program Files (x86)\Steam\steamapps\common\Silent Hunter 3.
  2. Locate the sh3.exe file which should be near the end of the list of files.
  3. Right click on sh3.exe and select Properties.
  4. Navigate to the Compatibility tab.
  5. Enable Run this program in compatibility mode and select WIndows XP (Service Pack 3).
  6. Enable the option Run this program as administrator at the bottom of the window.
  7. Apply the changes and exit.
 
Test run the game
I advice you to test run the game to make sure everything wors properly before installing the mods. But how do I run the game without it crashing?
 
  1. Right click anywhere on your desktop and change your desktop resolution to 1024x768.
  2. Launch the game as you normally would and you should get to the main menu.
  3. Take this opportunity to navigate into the options menu and set the game to run in fullscreen.
  4. Save the settings and start up any mission to see if it loads into the game properly.
  5. Quit the game and change back your desktop resolution to your native resolution.
 
 
 
Required Mods
We need three mods to get the game properly working in any resolution. The fourth mod is The Grey Wolves Expansion Pack, which is optional but highly recommended for the ultimate experience.

Silent Hunter III 4GB Patch[ntcore.com]
Jonesoft Generic Mod Enabler[www.subsim.com]
Silent Hunter III Resolution Fix[www.subsim.com]
The Grey Wolves Expansion Pack[www.thegreywolves.com]
 
 
Installing the Mods
Silent Hunter III 4GB Patch
What you want to do first is installing the 4GB Patch which will extend the virtual memory the game can take advantage of on modern x64 systems. This will help alot if you plan on installing more mods, like the Grey Wolves Expansion Pack, and will improve stability. Silent Hunter III was developed for old operating systems with 2GB of virtual memory.
 
  1. Open the 4GB Patch archive and place the 4gb_patch.exe in the game installation folder C:\Program Files (x86)\Steam\steamapps\common\Silent Hunter 3.
  2. Make sure to run the patch as administartor.
  3. When the patch ask you to select a file make sure to select the sh3.exe file in the same folder.
  4. If everything went well the patch will tell you the executable were successfully patched.
  5. Sleect OK and you can now delete the patch from the installation folder.
 
Jonesoft Generic Mod Enabler
This is the tool we will use to install the Silent Hunter II Resolution Fix mod for in the next step. This is a very handly tool to organize your mods. You can load and unload mods and keep your mods in one separate folder for later use.
 
  1. Open the JSGME archive and run the jsgme_setup.exe from any location.
  2. When asked to provide an installation directory make sure to select the installation folder again.
  3. Finish the installation.
 
Silent Hunter III Resolution Fix
For the final part to get the vanilla version of the game to run in your desired resolution we will use JSGME to install this mod.
 
  1. Navigate to the installation folder again and there should be a MODS folder.
  2. Create a new folder in the MODS folder called Resolution Fix.
  3. Open the Resolution Fix archive and there should be two files called d3d9.cfg and d3d9.ini.
  4. Place the two files in the newly created Resolution Fix folder in the MODS folder.
  5. Run JSGME.exe located in the installation folder as administartor.
  6. Select the Resolution Fix from the left window and use the right arrow button to load it.
  7. To make sure the mod is successfully installed the two files d3d9.cfg and d3d9.ini should be in the installation folder.
  8. Open the newly created d3d9.cfg file in the installation folder with Notepad.
  9. Change resX= and resY= to your desired resolution. I use 2560x1440 so for me resX=2560 and resY=1440.
  10. Save the file and try to run the game using the sh3.exe file in the installation folder.
  11. If the game boots up in your desired resolution everything went well!

Share this post


Link to post
Share on other sites
9 hours ago, The Steel Coffin said:

Intanto grazie della lunga pappardella Von Faust, ho provato così al volo a duplicare la cartella semplicemente 

nei prossimi giorni provo ad operare con calma leggendo tutto quanto hai riportato

 

Ripeto, non conosco Steam però secondo me il problema potrebbe essere quello, lui va a cercarsi il gioco nel percorso di installazione.

Quindi se tu hai SH nel percorso C:\Program Files (x86)\Steam\steamapps\common\Silent Hunter 3

 

- Fare una copia della cartella originale:

     C:\Program Files (x86)\Steam\steamapps\common\Silent Hunter 3-originale

- Moddare SH e farti la copia della moddata:

     C:\Program Files (x86)\Steam\steamapps\common\Silent Hunter 3-moddata

 

A seconda di ciò che vuoi usare di volta in volta rinomini le cartelle con il nome originale:

C:\Program Files (x86)\Steam\steamapps\common\Silent Hunter 3

 

Forse 😁

Share this post


Link to post
Share on other sites

Negativo 😆

Posso fare tutte le copie che voglio ma è l'EXE di avvio che non funziona e mi da errore, qualcosa tipo load error 2:0000065etc....

in pratica è come se nel PC di exe per farlo partire ce ne deve essere soltanto uno, quello originario di steam appunto

 

No problem vedo di starci attento e caricare un mod alla volta senza far sovrascrivere nulla e usando il JSGME, peccato solo perchè avrei voluto fare come in passato e cioè tenerne uno liscio o solo con qualche mod qua e la, e un altro con installato il GWX che di fatto lo cambia profondamente e se ben ricordo rende incompatibile tanti altri mods ma dato che non si può avere tutto dalla vita ci gioco un po "liscio" e poi lo trasformerò in Grey Wolf

 

Share this post


Link to post
Share on other sites
1 hour ago, The Steel Coffin said:

Negativo 😆

Posso fare tutte le copie che voglio ma è l'EXE di avvio che non funziona e mi da errore, qualcosa tipo load error 2:0000065etc....

in pratica è come se nel PC di exe per farlo partire ce ne deve essere soltanto uno, quello originario di steam appunto

 

No problem vedo di starci attento e caricare un mod alla volta senza far sovrascrivere nulla e usando il JSGME, peccato solo perchè avrei voluto fare come in passato e cioè tenerne uno liscio o solo con qualche mod qua e la, e un altro con installato il GWX che di fatto lo cambia profondamente e se ben ricordo rende incompatibile tanti altri mods ma dato che non si può avere tutto dalla vita ci gioco un po "liscio" e poi lo trasformerò in Grey Wolf

 

Hai provato a spostare di volta in volta l'exe ORIGINALE?  eliminando di fatto gli  exe copiati

Share this post


Link to post
Share on other sites

Si ho provato ma da sempre lo stesso errore e non lo fa spostare

ma è inutile che sto li a diventarci matto, vedrò in futuro se è possibile anche perchè ho reiniziato da zero e per non farmi mancare nulla ho deciso di avere realismo 100% col risultato che non riesco a tirar giù nulla perchè i siluri vanno dove vogliono 🤣 mi devo leggere qualche guida con la dovuta calma e imparare da zero perchè in passato giocavo col puntatore automatico o come si chiama.. in pratica calcolava tutto lui e il siluro andava nel punto dove io tenevo puntato il periscopio, troppo palloso così ho preso questa drastica decisione

 

Piuttosto i problemi tecnici sembrano non abbandonarmi, dopo aver provato il game qualche volta per vedere se era ok ora mi accorgo che mezza roba audio non va più, non si sentono le voci quando do i vari comandi, le esplosioni dei siluri, gli scriccoglii vari quando si va giù o su, mentre si sentono i motori dall'intefono (le esplosioni dei siluri no neanche da quello però) che potrebbe essere successo?

Ho soltanto installato il SH Commander credendo di facilitarmi la vita impostando il nofatigue e cambiando la compressione del tempo e poi nullaltro

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Forum Statistics

    • Total Topics
      44,174
    • Total Posts
      508,611
×